You are browsing a read-only backup copy of Wikitech. The primary site can be found at wikitech.wikimedia.org

User talk:Chris Mytton

From Wikitech-static
Jump to navigation Jump to search

Welcome to Tool Labs!

Hello Chris Mytton, welcome to the Tool Labs project! Your request for access was processed and you should be able to log in now with ssh at login.tools.wmflabs.org. To get started, check the help page. You can also ask in our IRC channel at #wikimedia-cloud connect or send an e-mail to our mailing list labs-l@lists.wikimedia.org – thank you, and have fun using Tools! --StrikerBot (talk) 14:23, 12 August 2017 (UTC)

Thanks! Chris Mytton (talk) 10:50, 14 August 2017 (UTC)

verification-pages shut down

I have stopped the webservice for your verification-pages tool. It was in an infinite restart loop on the Kubernetes cluster with this error log output:

/data/project/verification-pages/ruby-2.4.1/lib/ruby/gems/2.4.0/gems/bundler-1.16.1/lib/bundler/spec_set.rb:88:in `block in materialize': Could not find libv8-6.3.292.48.1 in any of the sources (Bundler::GemNotFound)
        from /data/project/verification-pages/ruby-2.4.1/lib/ruby/gems/2.4.0/gems/bundler-1.16.1/lib/bundler/spec_set.rb:82:in `map!'
        from /data/project/verification-pages/ruby-2.4.1/lib/ruby/gems/2.4.0/gems/bundler-1.16.1/lib/bundler/spec_set.rb:82:in `materialize'
        from /data/project/verification-pages/ruby-2.4.1/lib/ruby/gems/2.4.0/gems/bundler-1.16.1/lib/bundler/definition.rb:170:in `specs'
        from /data/project/verification-pages/ruby-2.4.1/lib/ruby/gems/2.4.0/gems/bundler-1.16.1/lib/bundler/definition.rb:237:in `specs_for'
        from /data/project/verification-pages/ruby-2.4.1/lib/ruby/gems/2.4.0/gems/bundler-1.16.1/lib/bundler/definition.rb:226:in `requested_specs'
        from /data/project/verification-pages/ruby-2.4.1/lib/ruby/gems/2.4.0/gems/bundler-1.16.1/lib/bundler/runtime.rb:108:in `block in definition_method'
        from /data/project/verification-pages/ruby-2.4.1/lib/ruby/gems/2.4.0/gems/bundler-1.16.1/lib/bundler/runtime.rb:20:in `setup'
        from /data/project/verification-pages/ruby-2.4.1/lib/ruby/gems/2.4.0/gems/bundler-1.16.1/lib/bundler.rb:107:in `setup'
        from /data/project/verification-pages/ruby-2.4.1/lib/ruby/gems/2.4.0/gems/bundler-1.16.1/lib/bundler/setup.rb:20:in `<top (required)>'
        from /data/project/verification-pages/ruby-2.4.1/lib/ruby/site_ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /data/project/verification-pages/ruby-2.4.1/lib/ruby/site_ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /data/project/verification-pages/verification-pages/config/boot.rb:5:in `<top (required)>'
        from /data/project/verification-pages/verification-pages/bin/rails:8:in `require_relative'
        from /data/project/verification-pages/verification-pages/bin/rails:8:in `<main>'

cc: @Mhl20: --BryanDavis (talk) 23:48, 6 June 2018 (UTC)

@BryanDavis: Thanks, I've now sorted the error out and got the tool running again. Sorry if I caused any problems! Chris Mytton (talk) 15:35, 12 June 2018 (UTC)