You are browsing a read-only backup copy of Wikitech. The primary site can be found at wikitech.wikimedia.org

Talk:News/Tools Precise deprecation

From Wikitech-static
Jump to navigation Jump to search

Suppress errors

What if my tool only uses standard POSIX commands and should work on any release without tying me to a particular version that'll change in 2 years. Dispenser (talk) 22:44, 28 November 2016 (UTC)

If you don't specify -l release, your jobs will automatically start on Trusty nodes. valhallasw (Merlijn van Deen) (talk) 18:08, 29 November 2016 (UTC)
But that spits out a warning to stderr. Is there something like -l release="" or -l release=any to suppress the error message? —Dispenser (talk) 19:31, 29 November 2016 (UTC)
Either ignore the error, or pass -l release=trusty, as there will not be any newer SGE node (SGE will be retired in favor of k8s, as there is no supported version of SGE for newer debian/ubuntu versions). valhallasw (Merlijn van Deen) (talk) 22:13, 29 November 2016 (UTC)