Obsolete:Fundraising/tech/deployments/minfraud upgrade to 1.3

From Wikitech-static
Jump to navigation Jump to search

Show Stoppers

None right now

Change Sets

Deploying minFraud upgrade to 1.3

See the spike for minFraud upgrade behaviors.

There are two ways to go about this upgrade. The reason behind this is that you must deploy code and change settings at:

MaxMind minFraud version

Upgrade account first

If you upgrade the account before switching the libraries, you may get a notice about a missing index: score

( ! ) Notice: Undefined index: score in extensions/DonationInterface/extras/minfraud/ccfd/HTTPBase.php on line 407

minFraud is used as a filter, but the result from minFraud will not be used.

The donation will still get processed.

Upgrade code libraries first

Upgrading the libraries first appears the way to go:

  • There were no code errors
  • minFraud is able to properly flag orders regardless of the API specified at MaxMind.