You are browsing a read-only backup copy of Wikitech. The primary site can be found at wikitech.wikimedia.org

Dumps/Software dependencies

From Wikitech-static
Jump to navigation Jump to search

Software dependencies for running the dumps

(Incomplete list)

Note that on WMF production hosts, this is handled by a base install and by puppet.

The pile of python and C code used to manage these XML dumps needs the following:

  • python 3.5 or better
  • python3-yaml
  • php7 with bzip2 and gzip streams enabled
  • php7-mysql, php-xml, php-mbstring, any php extensions MediaWiki needs
  • functional base MediaWiki installation, including maintenance scripts
  • ActiveAbstract MW extension
  • Flow MW extension if you have Flow content in your wikis
  • mwbzutils (C utilities for manipulating bz2/gz-compressed MW xml files, in wikimedia repo)
  • mysqldump
  • curl (for api-based dumps jobs)
  • p7zip installed, 7za in path of user running the dumps
  • bzip2, lbzip2, gzip and supporting libraries